The 2018 ACM-ICPC Asia Qingdao Regional Contest, Online 青岛,C Halting Problem 模拟 + 卡常

博客目录

原题

传送门

作者: 浙江大学竞赛命题组

单位: ACMICPC

时间限制: 500 ms

内存限制: 64 MB

代码长度限制: 32 KB

In computability theory, the halting problem is the problem of determining, from a description of an arbitrary computer program, whether the program will finish running (i.e., halt) or continue to run forever.

Alan Turing proved in 1936 that a general algorithm to solve the halting problem cannot exist, but DreamGrid, our beloved algorithm scientist, declares that he has just found a solution to the halting problem in a specific programming language -- the Dream Language!

Dream Language is a programming language consists of only 5 types of instructions. All these instructions will read from or write to a 8-bit register r, whose value is initially set to 0. We now present the 5 types of instructions in the following table. Note that we denote the current instruction as the i-th instruction.

InstructionDescription
add vAdd v to the register r. As r is a 8-bit register, this instruction actually calculates (r+v)mod256 and stores the result into r, i.e. r←(r+v)mod256. After that, go on to the (i+1)-th instruction.
beq v kIf the value of r is equal to v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
bne v kIf the value of r isn't equal to v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
blt v kIf the value of r is strictly smaller than v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.
bgt v kIf the value of r is strictly larger than v, jump to the k-th instruction, otherwise go on to the (i+1)-th instruction.

A Dream Language program consisting of n instructions will always start executing from the 1st instruction, and will only halt (that is to say, stop executing) when the program tries to go on to the (n+1)-th instruction.

As DreamGrid's assistant, in order to help him win the Turing Award, you are asked to write a program to determine whether a given Dream Language program will eventually halt or not.

Input

There are multiple test cases. The first line of the input is an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤10​4​​), indicating the number of instructions in the following Dream Language program.

For the following n lines, the i-th line first contains a string s (s∈{“add”,“beq”,“bne”,“blt”,“bgt”}), indicating the type of the i-th instruction of the program.

  • If s equals to "add", an integer v follows (0≤v≤255), indicating the value added to the register;
  • Otherwise, two integers v and k follow (0≤v≤255, 1≤k≤n), indicating the condition value and the destination of the jump.

It's guaranteed that the sum of n of all test cases will not exceed 10​5​​.

Output

For each test case output one line. If the program will eventually halt, output "Yes" (without quotes); If the program will continue to run forever, output "No" (without quotes).

Sample Input

4
2
add 1
blt 5 1
3
add 252
add 1
bgt 252 2
2
add 2
bne 7 1
3
add 1
bne 252 1
beq 252 1

Sample Output

Yes
Yes
No
No

Hint

For the second sample test case, note that r is a 8-bit register, so after four "add 1" instructions the value of r will change from 252 to 0, and the program will halt.

For the third sample test case, it's easy to discover that the value of r will always be even, so it's impossible for the value of r to be equal to 7, and the program will run forever.

思路

就是模拟啦,注意扣常数

AC代码

#include<cstring>
#include<bits/stdc++.h>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int MOD=256;
struct Ins
{
    char s[10];
    int v,k;
}ins[10005];
bool vis[10005][258];
int main()
{
    int T;int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(register int i=1;i<=n;i++)
        {
            scanf("%s%d",ins[i].s,&ins[i].v);
            if(ins[i].s[1]!='d')
                scanf("%d",&ins[i].k);
            //printf("%s %d %d\n",ins[i].s,ins[i].v,ins[i].k);
        }
        memset(vis,0,sizeof(vis));
        unsigned char register reg=0;
        bool flag=0;
        for(int register i=1;i<=n;)
        {
            //printf("%d %d\n",reg,i);
            if(vis[i][reg])
            {
                flag=1;
                break;
            }
            else
            {
                vis[i][reg]=1;
            }
            if(ins[i].s[1]=='d')
            {
                reg=(reg+ins[i].v);
                ++i;
            }
            else if(ins[i].s[1]=='e')
            {
                if(ins[i].v==reg)
                    i=ins[i].k;
                else
                    ++i;
            }
            else if(ins[i].s[1]=='n')
            {
                if(ins[i].v!=reg)
                    i=ins[i].k;
                else
                    ++i;
            }
            else if(ins[i].s[1]=='l')
            {
                if(reg<ins[i].v)
                    i=ins[i].k;
                else
                    ++i;
            }
            else
            {
                if(reg>ins[i].v)
                    i=ins[i].k;
                else
                    ++i;
            }
        }
        if(flag)
            printf("No\n");
        else
            printf("Yes\n");
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值