A hard puzzle hdu 1097 数论,规律,循环节

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25110    Accepted Submission(s): 8940


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9 6
 

Author
eddy
 

Recommend
JGShining



我们在做这个题目的时候要清楚一点,就是这个最后一个值是有规律的,所以我们查找循环节的方法来找就是了!!!!
还有就是我本来用java的API想直接做的,但是事实告诉我这样只能超时,唉,看来没有规律是不行的啊!!!!



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{

    long long  a,b;
    int i,j;
    int num[100];
    while(cin>>a>>b)
    {
        a=a%10;
        num[0]=1;
        num[1]=a;
        int flag=1;
        long long  sum=a;
        int st,en;
        for(i=2;i<=100&&flag;i++)
        {
            sum=sum*a;
            sum=sum%10;
            num[i]=sum;
            for(j=2;j<i;j++)
            {
                if((num[i]==num[j])&&(num[i-1]==num[j-1]))
                {
                    st=j;
                    en=i;
                   // printf("%d%d",st,en);
                    flag=0;
                    break;
                }
            }




        }
         if(!flag)
         {
             printf("%d\n",num[st+(b-en)%(en-st)]);

         }
    }
    return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值