2016暑期训练4C-PrimePath(POJ3126)

C - Prime Path
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
这道题直接用bfs暴力搜索,最好打个素数表以防超时。在给这个四位素数的每一位换元素的时候出了点问题,反正就是思路不对,WA了多次。本来觉得很简单的,没想到是个坑。还是那句话,对于菜鸟来说,其实是没有水题和难题之分的,因为他们能把所有的水题都做成难题啊难过
水水的代码如下:
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;

struct node{
    int n;
    int cot;
};
node start,endp;
node q[100000];
int prime[10010];
int vis[10010];
void asprime()
{
    prime[0]=prime[1]=0;
    for(int i=2;i<10000;i++)
    {
        if(prime[i]==-1)
        {
            prime[i]=1;
            for(int j=2*i;j<10000;j+=i)
                prime[j]=0;
        }
    }
}
void bfs()
{
    int front=0,rear=0;
    int flag=0;
    q[rear++]=start;
    vis[start.n]=1;
    node t,tmp;
    while(front<rear)
    {
        t=q[front++];
        //cout<<t.n<<endl;
        if(t.n==endp.n){flag=1;break;}
        for(int i=0;i<4;i++)
        {
            for(int j=0;j<10;j++)
            {
                if(i==0) tmp.n=t.n/10*10+j;
                else if(i==1) tmp.n=t.n/100*100+j*10+t.n%10;
                else if(i==2) tmp.n=t.n/1000*1000+j*100+t.n%100;
                else if(j==0) continue;
                else {tmp.n=j*1000+t.n%1000;}

                if(!vis[tmp.n]&&prime[tmp.n])
                {
                    tmp.cot=t.cot+1;
                    q[rear++]=tmp;
                    vis[tmp.n]=1;
                }
            }
        }
    }
    if(flag) cout<<t.cot<<endl;
    else cout<<"Impossible"<<endl;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int T;
    cin>>T;
    while(T--)
    {
        memset(prime,-1,sizeof(prime));
        memset(vis,0,sizeof(vis));
        asprime();
        cin>>start.n>>endp.n;
        start.cot=0;
        bfs();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值