poj3278(求最短路径,广搜)

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 119311 Accepted: 37232

Description

农夫知道一头牛的位置,想要抓住它。农夫和牛都位于数轴上 ,农夫起始位于点 N(0<=N<=100000) ,牛位于点 K(0<=K<=100000) 。农夫有两种移动方式:
1、从 X移动到 X-1或X+1 ,每次移动花费一分钟
2、从 X移动到 2*X ,每次移动花费一分钟
假设牛没有意识到农夫的行动,站在原地不动。农夫最少要花多少时间才能抓住牛?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

首先想到广搜,一层一层的搜索,这时只需n行就能到达n点所在的层数

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define p 100010
using namespace std;
int visit[p];
int n,k;
struct Catch{
    int step;
    int x;
    Catch(int xx,int s):x(xx),step(s){}
};
queue<Catch> q;
int main(){
    scanf("%d %d",&n,&k);
    memset(visit,0,sizeof(visit));
    q.push(Catch(n,0));
    visit[n]=1;
    while(!q.empty()){
        Catch c=q.front();
        q.pop();
        if(c.x==k)
        {
            printf("%d\n",c.step);
            return 0;
        }
        else
        {
           if(c.x-1>=0&&!visit[c.x-1])
           {
               q.push(Catch(c.x-1,c.step+1));
               visit[c.x-1]=1;
               //printf("c1:%d\n",c.step+1);
           }
           if(c.x+1<p&&!visit[c.x+1])
           {
              q.push(Catch(c.x+1,c.step+1));
               visit[c.x+1]=1;
               //printf("c2:%d\n",c.step+1);
           }
           if(c.x*2<p&&!visit[c.x*2])
           {
              q.push(Catch(c.x*2,c.step+1));
               visit[c.x*2]=1;
               //printf("c3:%d\n",c.step+1);
           }
        }

    }
}










 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值