HDU——1520Anniversary party

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
   
   
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
   
   
5
 

Source
 

树形dp入门题,我们用数组dp[rt][1]表示当前节点选入, dp[rt][0]表示当前节点不选入,最后答案就是max(dp[rt][1],dp[rt][0]),
那么如果当前节点选入的话,他的下一个节点就不能选,如果当前节点不选入,那么他的下一个节点可选可不选。
所以状态转移方程就是
     dp[rt][1]+=dp[子节点][0];
    dp[rt][0]+=max(dp[子节点][0],dp[子节点][1])
另外树形dp一定要深搜到树的最底层再返回来求个各个节点的属性。

#include<stdio.h>
#include<vector>
#include<string.h>
const int maxn=6010;
using namespace std;

vector<int>tree[maxn];
int dp[maxn][2];
int value[maxn];
int root[maxn];
int max(int a,int b)
{
return a>b?a:b;
}
void dfs(int rt)
{
int size=tree[rt].size();
dp[rt][1]=value[rt];
for(int i=0;i<size;i++)
dfs(tree[rt][i]);//树形dp,深搜到底层,
for(int i=0;i<size;i++)
{
dp[rt][1]+=dp[tree[rt][i]][0];
dp[rt][0]+=max(dp[tree[rt][i]][1],dp[tree[rt][i]][0]);
}
}


int main()
{
int n;
while(~scanf("%d",&n))
{
int x,y;
int rt;
for(int i=1;i<=n;i++)
{
scanf("%d",&value[i]);
root[i]=-1;
tree[i].clear();
}
memset(dp,0,sizeof(dp));
while(1)
{
scanf("%d%d",&x,&y);
if(x==0 && y==0)
break;
tree[y].push_back(x);
root[x]=y;
if(root[y]==-1)
rt=y;
}
dfs(rt);
printf("%d\n",max(dp[rt][0],dp[rt][1]));
}
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值