Description
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.
Input
Output
Sample Input
4 6 1 2 1 1 3 1 1 4 2 2 3 1 3 4 1 2 4 1
Sample Output
1 4 1 2 1 3 2 3 3 4
水题。求一个最小生成树的边,以及最大边。。。用的是克鲁斯卡尔算法
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
int s,t,dist;
}edge[15005];
int father[1010];
struct ust
{
int x,y;
}used[1010];
int cmp(node a,node b)
{
return a.dist < b.dist;
}
void unit(int n)
{
for(int i=0;i<=n;i++)
father[i]=i;
}
int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}
void Union(int a,int b)
{
int fa=find(a);
int fb=find(b);
if(fa!=fb)
father[fa]=fb;
}
int main()
{
int n,m,cnt;
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<m;i++)
scanf("%d%d%d",&edge[i].s,&edge[i].t,&edge[i].dist);
unit(n);
cnt=0;
int max_len=-1;
sort(edge,edge+m,cmp);
for(int i=0;i<m;i++)
{
int a=edge[i].s;
int b=edge[i].t;
int aa=find(a);
int bb=find(b);
if(aa!=bb)
{
Union(aa,bb);
if(max_len<edge[i].dist)
max_len=edge[i].dist;
used[cnt].x=a;
used[cnt++].y=b;
if(cnt==n-1)
break;
}
}
printf("%d\n",max_len);
printf("%d\n",cnt);
for(int i=0;i<cnt;i++)
printf("%d %d\n",used[i].x,used[i].y);
}
return 0;
}