【最小生成树专题】POJ 1861 Network(瓶颈生成树)

http://bailian.openjudge.cn/practice/1861/

1861:Network

描述

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

输入

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

输出

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

样例输入

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

样例输出

1
4
1 2
1 3
2 3
3 4

来源

Northeastern Europe 2001, Northern Subregion

思路

题目大意:给你一个N个点和M条边的图,现在要你从这M条边中选一些边的集合,使得单边的长度的最大值最小且所有N个点要连通.要你输出:单边长度的最大值,选的边数目,每条边的两个端点号.
背景知识:最小瓶颈生成树问题是指,给出一个加权无向图,求一颗生成树,使得最大边权值尽量小。由于只关心最大权值,我们可以从一个空图开始,按照权值从小到大的顺序依次加入各条边,当图第一次连通时,对应的树即最小瓶颈生成树。而这个算法过程和kruscal算法完全一样,所以最小生成树一定是最小瓶颈生成树(反过来说不成立,最小瓶颈生成树不一定是最小生成树)。这道题目没有说一定要求一颗树,只要能将图中各点都连通即可,可以多加一些边使得图中有环存在,比如样例。

思路:其实这道题目并没有要求我们求最小生成树,只是要我们求出让图连通的最长边最短的那个值.其实这就是最小瓶颈生成树.可以用kruskal算法求出最小生成树,然后输出最后选的那条边长即可.输出示例对于只有4个点的例子输出了4条边,因为你该图有多余的边,不是树.最终要求连通且最长边最短。

我觉得正确的输出结果应该是:

1 2
1 3
3 4

Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
typedef long long ll;
using namespace std;
const int nmax=2010;
const int mmax=1e4+10;
int n,m;//点数、边数 
int maxval;//生成树的最大边 
int vis[mmax];//判断m条边是否都使用过了 

struct Edge{
	int u,v;
	ll val;
}edge[mmax],tmp[mmax]; 
bool cmp(Edge a,Edge b){
	return a.val<b.val;//按照边权从小到大排序,求最小生成树 
}
int father[nmax]; 
int findFather(int u){
	if(u==father[u]) return u;
	else{
		int f=findFather(father[u]);
		father[u]=f;
		return f;
	}
}
void init(int n){
	for(int i=1;i<=n;i++){//点编号:1~n 
		father[i]=i;
	}
}
 
void Kruskal1(){//求出最小生成树中的最大边
	init(n);
	ll ans=0;
	ll cnt=0; 
	for(int i=0;i<m;i++){//边编号:0~m-1 
		int fu=findFather(edge[i].u);
		int fv=findFather(edge[i].v);
		 
		if(fu!=fv){
			father[fu]=fv;
			ans+=edge[i].val;
			//tmp[cnt].u=edge[i].u;
			//tmp[cnt++].v=edge[i].v;
			cnt++;
			vis[i]=1;
			if(maxval<edge[i].val){//贪心找最大边 
				maxval=edge[i].val;
			} 
		}
	}
	printf("%lld\n",maxval);
	printf("%lld\n",cnt);
	/*for(int i=0;i<cnt;i++){
		printf("%d %d\n",tmp[i].u,tmp[i].v);
	}*/
	for(int i=0;i<m;i++){
		if(vis[i]==1){
			printf("%d %d\n",edge[i].u,edge[i].v);
		}
	}
}
 
 
 
int main(int argc, char** argv) {
	while(scanf("%d %d",&n,&m)!=EOF){
		memset(vis,0,sizeof(vis));
		memset(father,0,sizeof(father));
		for(int i=0;i<m;i++){
			scanf("%d %d %lld",&edge[i].u,&edge[i].v,&edge[i].val);
		}
		sort(edge,edge+m,cmp);
		maxval=-0x3f3f3f3f;
	    Kruskal1();//求出最小生成树的最大边
		
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值