HDU4738——Caocao's Bridges

Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

Sample Input
  
  
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

Sample Output
  
  
-1 4
 

Source
 

Recommend




这题坑点太多,如果一开始就不连通,那么就是0,如果最小答案是0,那还是要去一个

还有就是重边的判定。


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

const int maxn=1005;
const int INF=0x3f3f3f3f;
struct node
{
	int id;
    int to;
    int next;
    int weight;
}edge[maxn*maxn];
int head[maxn];
int father[maxn];
int low[maxn];
int DFN[maxn];
bool instack[maxn];
int bridge[maxn];
int cnt,tot,index,res;

int find(int x)
{
    if (father[x]==-1)
        return x;
    father[x]=find(father[x]);
    return father[x];
}

void merge(int x,int y)
{
    int a=find(x);
    int b=find(y);
    if (a!=b)
    {
        father[a]=b;
        cnt--;
    }
}

void addedge(int from,int to,int weight,int id)
{
	edge[tot].id=id;
    edge[tot].to=to;
    edge[tot].weight=weight;
    edge[tot].next=head[from];
    head[from]=tot++;
}

void tarjan(int u,int fa)
{
    DFN[u]=low[u]=++index;
    instack[u]=1;
    for (int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].to;
        if (edge[i].id==fa)
        	continue;
        //printf("%d %d\n",u,v);
        if (!instack[v])
        {
            tarjan(v,edge[i].id);
            if (low[u]>low[v])
                low[u]=low[v];
            if (low[v]>DFN[u])
                bridge[res++]=edge[i].weight;
        }
        else if (low[u]>DFN[v])
            low[u]=DFN[v];
    }
}

int solve(int n)
{
    memset(low,0,sizeof(low));
    memset(DFN,0,sizeof(DFN));
    memset(instack,0,sizeof(instack));
    int ans=INF;
    res=0;
    index=0;
    for (int i=1;i<=n;i++)
        if (!DFN[i])
            tarjan(i,-1);
    for (int i=0;i<res;i++)
        if (ans>bridge[i])
            ans=bridge[i];
    if (ans==INF)
        return -1;
    else if (ans==0)
        return 1;
    return ans;
}

int main()
{
    int n,m;
    while (~scanf("%d%d",&n,&m))
    {
        if (!n && !m)
            break;
        memset(head,-1,sizeof(head));
        memset(father,-1,sizeof(father));
        tot=0;
        cnt=n;
        int s,t,w;
        for (int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&s,&t,&w);
            addedge(s,t,w,i);
            addedge(t,s,w,i);
            merge(s,t);
        }
        if (cnt>1)
            printf("0\n");
        else
            printf("%d\n",solve(n));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值