hdu5014——Number Sequence

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 413    Accepted Submission(s): 199
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n]
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5017  5016  5015  5013  5011 
 

本题是特判题 ,所以只要找到任意的解就行了


0 1 2 3 4 5 ......n

依次用当前最大值去异或其他值,从那个位置开始从大到小填充,直到全部填完

另外要输出的最大值是有规律的,一个公差递增的数列


#include<cstdio>
#include<iostream>
#include<algorithm>

using namespace std;

int a[100010];
int b[100010];

int main()
{
	int n;
	while(~scanf("%d", &n))
	{
		for(int i = 0; i <= n; i++)
		{
			scanf("%d", &a[i]);
			b[i] = 0;
		}	
		int num = n;
		while( num >= 0 )
		{
			int pos = 0;
			int maxs = 0;
			int temp = -1;
			for(int i = 0; i <= num; i++)
			{
				temp = num ^ i;
				if(temp > maxs)
				{
					maxs = temp;
					pos = i;
				}
			}
			int idx = pos;
			while(b[idx] == 0 && idx <= n)
			{
				b[idx] = num;
				idx++;
				num--;
			}
		}
		printf("%I64d\n", (__int64)n * n + n);
		printf("%d", b[a[0]]);
		for(int i = 1; i <= n; i++)
			printf(" %d", b[a[i]]);
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值