hdu1003Max Sum && hdu 1231 最大连续子序列

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 147262    Accepted Submission(s): 34418


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1176  1069  2084  1058  1203


设dp[i] 表示 以元素i结尾时的最大值,显然 dp[i] = max (dp[i-1] + arr[i], arr[i] )

按这个方程可以找到最大值和产生最大值的序列的结束位置,但还需要一个开始位置,
求法是这样的,观察方程,只有当dp[i-1] <=0 时,dp[i] 才会取arr[i],所以从结束位置开始往前找,如果dp[i] >=0 说明 dp[i + 1] 一定是 dp[i] + arr[i+1],所以一定连在一起,反之,如果dp[i]<0,那么dp[i + 1] 一定是 arr[i+1],显然就从这里断开了,所以发现dp[i]<0就可以break了。再往前就是其他序列了。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

int dp[1000010];
int arr[1000010];

int main()
{
	int t, k;
	scanf("%d", &t);
	int icase = 1;
	bool flag = false;
	while(t--)
	//while(~scanf("%d", &k), k)
	{
		if(flag)
			printf("\n");
		else
			flag = true;
		scanf("%d", &k);
		for(int i = 0;i < k; i++)
			scanf("%d", &arr[i]);
		memset( dp, 0, sizeof(dp) );
		int s, e, ans = -0x3f3f3f;
		for(int i = 0; i < k; i++)
		{
			if(i == 0)
				dp[i] = arr[i];
			else
				dp[i] = max(dp[i - 1] + arr[i], arr[i]);
			if(dp[i] > ans)
			{
				ans = dp[i];
				e = i;
			}
		}
		s = e;
		for(int i = e - 1; i >= 0; i--)
		{
			if(dp[i] >= 0)
				s = i;
			else
				break;
		}
		printf("Case %d:\n", icase++);
		printf("%d %d %d\n", ans, ++s, ++e);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值