hdu5086——Revenge of Segment Tree

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 383    Accepted Submission(s): 163


Problem Description
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000
 

Output
For each test case, output the answer mod 1 000 000 007.
 

Sample Input
  
  
2 1 2 3 1 2 3
 

Sample Output
  
  
2 20
Hint
For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20. Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded. And one more little helpful hint, be careful about the overflow of int.
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5089  5088  5085  5084  5082 
 

显然枚举所有区间是不可能的,我们得找找规律什么的,可以发现,设所有数的和是sum, S1(区间长度为1)的是sum,S2 = 2 * sum - (a1 + an)
S3 = 3 * sum - (2 * a1 + a2 + 2 *an + a1)
再枚举几个就可以找到规律

所以,总的和里,从左往右看 a1出现了(n-1)*n/2次,a2是(n - 2)*(n - 1)/2次........................
从右往左看,an出现了(n-1)*n/2次,an-1是(n - 2)*(n - 1)/2次........................

所以在O(n)的时间里就完成了计算,注意用__int64以及取模

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

__int64 a[447100];
__int64 b[447100];
const __int64 mod = 1000000007;

int main()
{
	int t, n;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		__int64 ans = 0, x;
		__int64 sum = 0;
		for (int i = 1; i <= n; i++)
		{
			scanf("%I64d", &x);
			b[i] = x;
			a[i] = (__int64)(n - i) * (1 + n - i) / 2 % mod;
			sum += x;
			sum %= mod;
		}
		for (int i = 1; i <= n; i++)
		{
			a[i] = (__int64)a[i] * b[i] % mod;
		}
		for (int i = n; i >= 1; i--)
		{
			a[i] += (__int64)(i - 1) * i  / 2 % mod * b[i] % mod;
		}
		ans = (__int64) n * (n + 1) / 2 % mod * sum % mod;
		for (int i = 1; i <= n; i++)
		{
			ans -= a[i];
			ans %= mod;
			if (ans < 0)
			{
				ans += mod;
			}
			ans %= mod;
		}
		printf("%I64d\n", ans);
	}
	return 0;
}


# 高校智慧校园解决方案摘要 智慧校园解决方案是针对高校信息化建设的核心工程,旨在通过物联网技术实现数字化校园的智能化升级。该方案通过融合计算机技术、网络通信技术、数据库技术和IC卡识别技术,初步实现了校园一卡通系统,进而通过人脸识别技术实现了更精准的校园安全管理、生活管理、教务管理和资源管理。 方案包括多个管理系统:智慧校园管理平台、一卡通卡务管理系统、一卡通人脸库管理平台、智能人脸识别消费管理系统、疫情防控管理系统、人脸识别无感识别管理系统、会议签到管理系统、人脸识别通道管理系统和图书馆对接管理系统。这些系统共同构成了智慧校园的信息化基础,通过统一数据库和操作平台,实现了数据共享和信息一致性。 智能人脸识别消费管理系统通过人脸识别终端,在无需接触的情况下快速完成消费支付过程,提升了校园服务效率。疫情防控管理系统利用热成像测温技术、视频智能分析等手段,实现了对校园人员体温监测和疫情信息实时上报,提高了校园公共卫生事件的预防和控制能力。 会议签到管理系统和人脸识别通道管理系统均基于人脸识别技术,实现了会议的快速签到和图书馆等场所的高效通行管理。与图书馆对接管理系统实现了一卡通系统与图书馆管理系统的无缝集成,提升了图书借阅的便捷性。 总体而言,该智慧校园解决方案通过集成的信息化管理系统,提升了校园管理的智能化水平,优化了校园生活体验,增强了校园安全,并提高了教学和科研的效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值