hdu1546——Idiomatic Phrases Game

62 篇文章 0 订阅

Idiomatic Phrases Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2191    Accepted Submission(s): 712


Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
 

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
 

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
 

Sample Input
  
  
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
 

Sample Output
  
  
17 -1
 

Author
ZHOU, Ran
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1317  1245  1598  1531  1532 
 

水题

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
// #pragma comment(linker, "/STACK:102400000, 102400000")

using namespace std;

typedef pair<int, int> PLL;

const int N = 1010;
const int inf = 0x3f3f3f3f;
int head[N], tot;
int dist[N];
struct node
{
	int weight;
	int next;
	int to;
}edge[N * N];
struct node2
{
	int t;
	int len;
	char str[100];
}text[N];

void addedge(int from, int to, int weight)
{
	edge[tot].weight = weight;
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

void dijkstra(int v0)
{
	priority_queue < PLL, vector<PLL>, greater<PLL> > qu;
	memset (dist, inf, sizeof(dist));
	dist[v0] = 0;
	qu.push(make_pair(dist[v0], v0));
	while (!qu.empty())
	{
		PLL tmp = qu.top();
		qu.pop();
		int u = tmp.second;
		for (int i = head[u]; ~i; i = edge[i].next)
		{
			int v = edge[i].to;
			if (dist[v] > dist[u] + edge[i].weight)
			{
				dist[v] = dist[u] + edge[i].weight;
				qu.push(make_pair(dist[v], v));
			}
		}
	}
}

int main()
{
	int n;
	while(~scanf("%d", &n), n)
	{
		memset (head, -1, sizeof(head));
		tot = 0;
		for (int i = 0; i < n; ++i)
		{
			scanf("%d%s", &text[i].t, text[i].str);
			int len = strlen(text[i].str);
			text[i].len = len;
		}
		for (int i = 0; i < n; ++i)
		{
			for (int j = 0; j < n; ++j)
			{
				if (i == j)
				{
					continue;
				}
				int len = text[i].len;
				if (text[i].str[len - 1] == text[j].str[3] && text[i].str[len - 2] == text[j].str[2] && text[i].str[len - 3] == text[j].str[1] && text[i].str[len - 4] == text[j].str[0])
				{
					addedge(i, j, text[i].t);
				}
			}
		}
		dijkstra(0);
		if (dist[n - 1] == inf)
		{
			printf("-1\n");
		}
		else
		{
			printf("%d\n", dist[n - 1]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值