HDU——1546 Idiomatic Phrases Game (Dijkstra)最短路

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case. 

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

题意: 讲真题意网上搜的,实在看不懂,就是用第一个字符串找最后一个,用第一个的最后4个字符找第二个的前4个字符,用第二个的后4个字符找第三个的前4个字符知道找到第n个,找到输出最短时间(也就是最短路),找不到输出-1

题解:关键就是建图,其它的就是模板了,第一次写,优先队列,所以赶紧来写个博客。

上代码:

#include <iostream>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
const int inf=0x3f3f3f3f;
const int MAX=1500;
int dis[MAX],vis[MAX];
int n;
struct hh{
	int u;
	int v;
	int w;
	friend bool operator<(hh a,hh b)// 优先队列,按什么排序;注意重载写小于号,不能写大于号
    {
        return a.w>b.w;//这里大于号是从小到大,小于号是从大到小
    }

}tmp;
vector <hh> vs[MAX];//用vector存图
struct ww{
	int x;
	string s;
}a[MAX];
void init(){//初始化
	memset(vis,0,sizeof(vis));
	memset(dis,inf,sizeof(dis));
	for (int i = 0; i <= n;i++){
		vs[i].clear();
	}
}
void add(int u,int v,int w){//存图
	tmp.u=u;
	tmp.v=v;
	tmp.w=w;
	vs[u].push_back(tmp);
}
void Dijkstra(){
	priority_queue<hh> q;
	dis[1]=0;
	hh tmp1,tmp2;
	tmp1.v=1;
	tmp1.w=0;
	q.push(tmp1);
	while(!q.empty()){//优先队列写的方法
		tmp1=q.top();
		q.pop();
		if(vis[tmp1.v])	continue;
		vis[tmp1.v]=1;
		if(dis[tmp1.v]==inf) break;
		for (vector<hh>::iterator it=vs[tmp1.v].begin();it!=vs[tmp1.v].end();it++){
			if(vis[it->v]) continue;
			if(dis[it->v]>dis[tmp1.v]+it->w){	
				tmp2.v=it->v;
				tmp2.w=dis[tmp1.v]+it->w;
				dis[it->v]=tmp2.w;
				q.push(tmp2);
			}
		}
	}
}
int main(){
	std::ios::sync_with_stdio(false);//为了加速cin和cout
	cin.tie(0);cout.tie(0);
	while(cin >> n , n){
		init();
		for (int i = 1; i <= n;i++){
			cin >> a[i].x >> a[i].s;
		}
		for (int i = 1; i <= n;i++){
			for (int j = 1; j <= n;j++){
                int l=a[i].s.size();
				if(a[i].s[l-4]==a[j].s[0]&&a[i].s[l-3]==a[j].s[1]&&a[i].s[l-2]==a[j].s[2]&&a[i].s[l-1]==a[j].s[3]){
				add(i,j,a[i].x);//连接图,也就是存图
				/*string s1=a[i].s;//这样写会超时,可能字符串的复制,耗时间较多吧
				string s2=a[j].s;
				int l=s2.size();
				if(s1[l-4]==s2[0]&&s1[l-3]==s2[1]&&s1[l-2]==s2[2]&&s1[l-1]==s2[3]){
					add(i,j,a[i].x);
				}*/
			    }
			}
		}
		Dijkstra();
		if(dis[n]!=inf) cout << dis[n] << endl;
		else cout << -1 << endl;//如果等于inf说明找不到,也就是他的初始值没变,如果找到,它会有一个时间,而不是初始值
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值