hdu2476——String painter

194 篇文章 0 订阅

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1834    Accepted Submission(s): 814


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
  
  
6 7
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2480  2481  2478  2482  2475 
 

Statistic | Submit | Discuss | Note


区间dp,这题很特殊啊,要先考虑从空串变成第二个串,然后再利用这个信息去计算第一个串变成第二个串的最少次数


#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 110;
const int inf = 0x3f3f3f3f;
int dp[N][N];
int f[N];
char stra[N], strb[N];

int main()
{
	while(~scanf("%s%s", stra + 1, strb + 1))
	{
		int n = strlen(stra + 1);
		memset (dp, 0, sizeof(dp));
		memset (f, inf, sizeof(f));
		for (int i = 1; i <= n; ++i)
		{
			dp[i][i] = 1;
		}
		for (int i = n; i >= 1; --i)
		{
			for (int j = i + 1; j <= n; ++j)
			{
				dp[i][j] = dp[i + 1][j] + 1;
				for (int k = i + 1; k <= j; ++k)
				{
					if (strb[k] == strb[i])
					{
						dp[i][j] = min(dp[i][j], dp[i + 1][k] + dp[k + 1][j]);
					}
				}
			}
		}
		f[0] = 0;
		for (int i = 1; i <= n; ++i)
		{
			f[i] = dp[1][i];
		}
		for (int i = 1; i <= n; ++i)
		{
			if (stra[i] == strb[i])
			{
				f[i] = f[i - 1];
			}
			else
			{
				for (int j = 0; j < i; ++j)
				{
					f[i] = min(f[i], f[j] + dp[j + 1][i]);
				}
			}
		}
		printf("%d\n", f[n]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值