hdu3076----ssworld VS DDD

194 篇文章 0 订阅

ssworld VS DDD

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1549    Accepted Submission(s): 320


Problem Description
One day, sssworld and DDD play games together, but there are some special rules in this games.
They both have their own HP. Each round they dice respectively and get the points P1 and P2 (1 <= P1, P2 <= 6). Small number who, whose HP to reduce 1, the same points will remain unchanged. If one of them becomes 0 HP, he loses.
As a result of technical differences between the two, each person has different probability of throwing 1, 2, 3, 4, 5, 6. So we couldn’t predict who the final winner.

 

Input
There are multiple test cases.
For each case, the first line are two integer HP1, HP2 (1 <= HP1, HP2 <= 2000), said the first player sssworld’s HP and the second player DDD’s HP.
The next two lines each have six floating-point numbers per line. The jth number on the ith line means the the probability of the ith player gets point j. The input data ensures that the game always has an end.
 

Output
One float with six digits after point, indicate the probability sssworld won the game.
 

Sample Input
  
  
5 5 1.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 1.000 5 5 0.000 0.000 0.000 0.000 0.000 1.000 1.000 0.000 0.000 0.000 0.000 0.000
 

Sample Output
  
  
0.000000 1.000000
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3069  3070  3071  3073  3074

此题略坑, 第一个值a是第二个人的hp,第二个值b才是第一个人的
令dp[i][j]表示第一个人赢了i次,第二个人赢了j次的概率

当然转移的时候要注意如果(第一个人赢了a次,那么他已经赢了,就不用去转移了,同样第二个人赢了b次,也不用去转移)

/*************************************************************************
    > File Name: hdu3076.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2014年12月22日 星期一 10时35分19秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const int N = 2005;

double dp[N][N];
double x[10], y[10];

int main()
{
	int a, b;
	double p1, p2, p3;
	while (~scanf("%d%d", &a, &b))
	{
		p1 = p2 = p3 = 0;
		for (int i = 0; i < 6; ++i)
		{
			scanf("%lf", &x[i]);
		}
		for (int i = 0; i < 6; ++i)
		{
			scanf("%lf", &y[i]);
		}
		for (int i = 0; i < 6; ++i)
		{
			for (int j = 0; j < i; ++j)
			{
				p1 += x[i] * y[j];
			}
		}
		for (int i = 0; i < 6; ++i)
		{
			for (int j = 0; j < i; ++j)
			{
				p2 += y[i] * x[j];
			}
		}
		p3 = 1.0 - p1 - p2;
		p1 /= (1.0 - p3);
		p2 /= (1.0 - p3);
		memset (dp, 0, sizeof(dp));
		dp[0][0] = 1.0;
//		printf("%f %f %f\n", p1, p2, p3);
		for (int i = 0; i <= a; ++i)
		{
			for (int j = 0; j <= b; ++j)
			{
				if (j < b && i > 0)
				{
					dp[i][j] += p1 * dp[i - 1][j];
				}
				if (i < a && j > 0)
				{
					dp[i][j] += p2 * dp[i][j - 1];
				}
			}
		}
		double ans = 0;
		for (int i = 0; i < b; ++i)
		{
			ans += dp[a][i];
		}
		printf("%lf\n", ans);
	}
	return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值