hdu4336-----Card Collector

194 篇文章 0 订阅

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2785    Accepted Submission(s): 1321
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   4337  4331  4332  4333  4334 
 

简单的概率dp,发现n最多只有20,所以状态压缩来搞定
dp[i] 表示 买到卡片的状态为i时,买齐卡片所需要的期望值
ans = dp[0]
dp[(1 << n) - 1] = 0;
转移方程里分为2块,第一块是此状态里有的卡片, 第二块里是状态里没有的和没买到卡片的

/*************************************************************************
    > File Name: hdu4336.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2014年12月23日 星期二 14时48分32秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const int N = (1 << 20) + 10;
int n;
double dp[N];
double p[30], vp;

double dfs(int s)
{
	if (dp[s] != -1)
	{
		return dp[s];
	}
	double x = 0, y = 0;
	for (int i = 0; i < n; ++i)
	{
		if (!(s & (1 << i))) //这种状态下i没有抽到过
		{
			x += p[i] * (dfs(s | (1 << i)) + 1);
		}
		else
		{
			y += p[i];
		}
	}
	y += vp;
	return 	dp[s] = (x + y) / (1 - y);	
}

int main()
{
	while (~scanf("%d", &n))
	{
		vp = 0;
		for (int i = 0; i < n; ++i)
		{
			scanf("%lf", &p[i]);
			vp -= p[i];
		}
		vp += 1;
		for (int i = 0; i <= (1 << n); ++i)
		{
			dp[i] = -1.0;
		}
		dp[(1 << n) - 1] = 0;
		printf("%f\n", dfs(0));
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值