hdu 4336 Card Collector (概率与期望+状压DP)

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4305    Accepted Submission(s): 2168
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
  
  
1 0.1 2 0.1 0.4
 

Sample Output
  
  
10.000 10.500
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   4337  4331  4332  4333  4334 
 

Statistic |  Submit |  Discuss | Note

题解:概率与期望+状压DP

还是需要逆着推,f[(1<<n)-1]=0

然后枚举j,判断这个位置是否已经出现过来

f[i]=(f[i|(1<<j)]+1)*p[j]+(f[i]+1)*p[k] j表示的是i状态中没出现的,k表示的是i状态中出现过的以及空包的概率。

然后移项,求f[i]即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int n;
double f[1<<21],p[23];
int main()
{
	freopen("a.in","r",stdin);
	while (scanf("%d",&n)!=EOF) {
		memset(f,0,sizeof(f)); double p1=1.0;
		for (int i=0;i<n;i++) scanf("%lf",&p[i]),p1-=p[i];
		//cout<<p1<<endl;
		f[(1<<n)-1]=0;
		for (int i=(1<<n)-2;i>=0;i--) {
			f[i]=0;
			int t=i; double sum=p1;
			for (int j=0;j<n;j++)
			 if ((t>>j)&1) sum+=p[j];
			 else  f[i]+=(f[i|(1<<j)]+1)*p[j];
		    f[i]+=sum; //cout<<f[i]<<" "<<(1.0-sum)<<endl;
		    f[i]/=(double)(1.0-sum);
		}
		printf("%.4lf\n",f[0]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值