POJ1847---Tram

94 篇文章 0 订阅
62 篇文章 0 订阅
Tram
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10622 Accepted: 3877

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

Source

Croatia OI 2002 Regional - Juniors

最短路上不会有环,所以每个点顶多走过一次,那么就不需要去考虑走过这个点以后,开关的位置,所以直接按起始时开关位置建图,然后floyd就行

/*************************************************************************
    > File Name: poj1847.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月05日 星期四 14时37分08秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;
const int N = 110;
int dp[N][N];

int main ()
{
	int n, a, b;
	while (~scanf("%d%d%d", &n, &a, &b))
	{
		memset (dp, inf, sizeof(dp));
		int k, j;
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &k);
			if (k == 0)
			{
				continue;
			}
			k--;
			scanf("%d", &j);
			dp[i][j] = 0;
			while (k--)
			{
				scanf("%d", &j);
				dp[i][j] = 1;
			}
		}
		for (int i = 1; i <= n; ++i)
		{
			dp[i][i] = 0;
		}
		for (int k = 1; k <= n; ++k)
		{
			for (int i = 1; i <= n; ++i)
			{
				for (int j = 1; j <= n; ++j)
				{
					dp[i][j] = min (dp[i][k] + dp[k][j], dp[i][j]);
				}
			}
		}
		if (dp[a][b] != inf)
		{
			printf("%d\n", dp[a][b]);
		}
		else
		{
			printf("-1\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值