hdu3182---Hamburger Magi(状压dp)

194 篇文章 0 订阅

Problem Description
In the mysterious forest, there is a group of Magi. Most of them like to eat human beings, so they are called “The Ogre Magi”, but there is an special one whose favorite food is hamburger, having been jeered by the others as “The Hamburger Magi”.
Let’s give The Hamburger Magi a nickname “HamMagi”, HamMagi don’t only love to eat but also to make hamburgers, he makes N hamburgers, and he gives these each hamburger a value as Vi, and each will cost him Ei energy, (He can use in total M energy each day). In addition, some hamburgers can’t be made directly, for example, HamMagi can make a “Big Mac” only if “New Orleams roasted burger combo” and “Mexican twister combo” are all already made. Of course, he will only make each kind of hamburger once within a single day. Now he wants to know the maximal total value he can get after the whole day’s hard work, but he is too tired so this is your task now!

Input
The first line consists of an integer C(C<=50), indicating the number of test cases.
The first line of each case consists of two integers N,E(1<=N<=15,0<=E<=100) , indicating there are N kinds of hamburgers can be made and the initial energy he has.
The second line of each case contains N integers V1,V2…VN, (Vi<=1000)indicating the value of each kind of hamburger.
The third line of each case contains N integers E1,E2…EN, (Ei<=100)indicating the energy each kind of hamburger cost.
Then N lines follow, each line starts with an integer Qi, then Qi integers follow, indicating the hamburgers that making ith hamburger needs.

Output
For each line, output an integer indicating the maximum total value HamMagi can get.

Sample Input

1
4 90
243 464 307 298
79 58 0 72
3 2 3 4
2 1 4
1 1
0

Sample Output

298

Source
HDU 2009-10 Programming Contest

Recommend
lcy | We have carefully selected several similar problems for you: 3180 3176 3178 3179 3175

dp[i]表示做汉堡的状态为i时得到的最多的能量

/*************************************************************************
    > File Name: hdu3182.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年04月28日 星期二 11时29分32秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

int V[20], C[20];
int dp[(1 << 15) + 10];
int use[20];

int main() {
    int t;
    scanf("%d", &t);
    while (t--) {
        int n, E;
        scanf("%d%d", &n, &E);
        memset(dp, -1, sizeof(dp));
        dp[0] = 0;
        memset(use, 0, sizeof(use));
        for (int i = 0; i < n; ++i) {
            scanf("%d", &V[i]);
        }
        for (int i = 0; i < n; ++i) {
            scanf("%d", &C[i]);
        }
        int m, tmp;
        for (int i = 0; i < n; ++i) {
            scanf("%d", &m);
            while (m--) {
                scanf("%d", &tmp);
                --tmp;
                use[i] |= (1 << tmp);
            };
        }
        for (int i = 0; i < (1 << n); ++i) {
            int cost = 0;
            for (int j = 0; j < n; ++j) {
                if (i & (1 << j)) {
                    cost += C[j];
                }
            }
            if (cost > E) {
                continue;
            }
            for (int j = 0; j < n; ++j) {
                if (!(i & (1 << j)) && dp[i] != -1) {
                    if ((use[j] & i) == use[j]) {
                        if (cost + C[j] <= E) {
                            dp[i | (1 << j)] = max(dp[i | (1 << j)], dp[i] + V[j]);;
                        }
                    }
                }
            }
        }
        int ans = 0;
        for (int i = 0; i < (1 << n); ++i) {
            ans = max(ans, dp[i]);
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值