Problem
DescriptionGiven a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
[hint]
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
[/hint]
#include<stdio.h>
long long qiuckpow( long long n)
{
long long ans=1;
long long a=n;
while(n!=0)
{
if(n&1)
{
ans=(ans*a)%10;
}
a=a*a;
n>>=1;
}
return ans;
}
int main()
{
long long t,n;
scanf("%lld",&t);
while(t--)
{
scanf("%lld",&n);
printf("%lld\n",qiuckpow(n));
}
return 0;
}