hdu-Rightmost Digit(快速幂取模经典题)

 Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input

2
3
4

Sample Output

7
6    

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

代码分析:快速幂原理 同余定理 这道题求个位数,直接mod10就OK。

	//hdu-Rightmost Digit 
#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
ll fmod(ll a,ll b,int mod){
	//a^b(大数)%c
	ll r=1;
	a=a%mod;//保证不会直接溢出,如果b很大 
	while(b>0){
		if(b%2==1)
			r=(r*a)%mod;
		b/=2;
		a=(a*a)%mod;	
	}
	return r;
}

int main(){
	int t;ll n;
	cin>>t;
	while(t--){
		cin>>n;
		cout<<fmod(n,n,10)<<"\n"; //求个位数直接模10 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值