hdoj1061 Rightmost Digit(快速幂+简单思路)

117 篇文章 0 订阅
5 篇文章 0 订阅

Description

Given a positive integer N, youshould output the most right digit of N^N. 


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题意:求n的n次方的最后一位数。

思路:快速幂,降幂计算不会超时。

代码:

#include<cstdio>
__int64 quickpow(__int64 n,__int64 m,__int64 mod)
{
	__int64 ans=1,base=n;
	while(m)
	{
		if(m&1)
		{
			ans=(base*ans)%mod;
		}
		base=(base*base)%mod;
		m/=2;
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
	__int64 n;
	scanf("%I64d",&n);
	printf("%I64d\n",quickpow(n,n,10));	
	}
	return 0;
}

还有一种方法就是用字符串。记录n的最后一位数,0~9的n次方尾数至多有四种情况。

0.1.5.6.9的n次方还是等于其本身

2=[2,4,8,6],3=[3,9,7,1],4=[4,6],7=[7,9,3,1],8=[8,4,2,6].

所以可以用n对4取余是几就是第几个数。可以打表来做也可以直接写

打表的话char a[4][10]={{0,1,2,3,4,5,6,7,8,9},{0,1,4,9,6,5,6,9,4,1},{0,1,8,7,4,5,6,3,2,9},{0,1,6,1,5,6,1,6,1}};

对四取余的m后直接输出a[m][n].

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a;
		scanf("%d",&a);
		int k=a%10;
		if(k==0||k==1||k==5||k==6||k==9)
		{
			printf("%d\n",k);
		}
		else
		{
			if(k==2)
			{
			if(a%4==0)
			printf("6\n");
			else
			printf("4\n");	
			}
			if(k==3)
			{
				if(a%4==1)
				printf("3\n");
				else
				printf("7\n");
			}
			if(k==4)
			printf("6\n");
			if(k==7)
			{
				if(a%4==1)
				printf("7\n");
				else
				printf("3\n");
			}
			if(k==8)
			{
				if(a%4==0)
				printf("6\n");
				else
				printf("4\n");
			}
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值