06-图2 Saving James Bond - Easy Version

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.
Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

利用Visual C++ 6.0编写的代码如下:

#include <stdio.h>
#include <math.h>
#define maxvertexnum 101  //最大顶点数设为101

struct Crocodile //定义鳄鱼的结构坐标
{
	int x;
	int y;
}cor[maxvertexnum];

int N,D; //N为鳄鱼的数目,D为007跳跃的最大距离
bool result =false ; //储存结果,判断能否逃脱
bool visit[maxvertexnum] = {false};//初始化,每个鳄鱼都没被访问

double distance(int i,int j); //计算i,j两点的距离,并返回
bool canjump(int i); //判断从当前鳄鱼i能不能一次逃脱
bool DFS( struct Crocodile cor[], int v, bool visit[]);//深度搜索,遍历

int main (void)
{
	int i;
	scanf("%d %d", &N, &D);

	//输入鳄鱼的坐标
	cor[0].x = 0;
	cor[0].y = 0; //小岛的坐标为(0,0)
	for(i = 1;i <= N; i++)
	{
		scanf("%d %d",&cor[i].x ,&cor[i].y);
	}

	visit[0] = true;
	for(i = 1;i <= N; i++)
	{
		if (distance(0,i) <=(D+7.5))//007从岛跳上第一个鳄鱼
		{
			result = DFS( cor, i, visit);
			if( result )
			{
				printf("Yes\n");
				break;
			}
		}
	}

	if(!result)
	{
		printf("No\n");
	}
	
	return 0;
}

double distance(int i,int j)
{
	double L;
	L = sqrt(pow(cor[i].x - cor[j].x , 2) + pow(cor[i].y - cor[j].y ,2));
	return L;
}

bool canjump (int i)
{
	if( (cor[i].x <= D-50 || cor[i].y <=D-50 ) || (cor[i].x >= 50-D || cor[i].y >= 50-D ))//007能够跳上去
	{
		return true;
	}
	else
	{
		return false;
	}	
}

bool DFS( struct Crocodile cor[], int v, bool visit[])
{
	int i;
	visit[v] = true;

	if(canjump (v))
	{
		result = true;
	}
	else
	{
		for(i = 1; i <= N; i++)
		{
			if( (visit[i] == false) && (distance(v,i) <= D))//i点没有被访问过,并且007能够跳过去
			{
				result = DFS(cor, i, visit);
			}
		}
	}
	return result;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值