矩阵快速幂(模板)

poj3070
快速幂模板:

 while(b){
   	if(b&1){
   		ans=ans*a%p;
   		
	   }
	a=a*a%p;
	b>>=1;
   }

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25547 Accepted: 17065
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const int mod=10000;
const int N=2;
ll tmp[N][N],res[N][N];
void multi(ll a[][N],ll b[][N],int n)
{
    memset(tmp,0,sizeof(tmp));
    for(ll i=0;i<n;i++)
    {
	   for(ll j=0;j<n;j++)
	   {
        for(ll k=0;k<n;k++)
        {
        tmp[i][j]+=(a[i][k]*b[k][j])%mod;
        }
        tmp[i][j]=tmp[i][j]%mod;
      }
   }
    for(ll i=0;i<n;i++)
        for(ll j=0;j<n;j++)
        a[i][j]=tmp[i][j];
}
void Pow(ll a[][N],ll m,int n)
{
    memset(res,0,sizeof(res));//m是幂,n是矩阵大小
    for(ll i=0;i<n;i++) res[i][i]=1;
    while(m)
    {
	    if(m&1)
        multi(res,a,n);//res=res*a;复制直接在multi里面实现了;
        multi(a,a,n);//a=a*a
        m>>=1;
    }
}
int main()
{
     ll m;
     int n;
     ll a[N][N]; 
    while(cin>>m&&m!=-1) 
    {  
         n=2;
    	a[0][0]=1,a[0][1]=1,a[1][0]=1,a[1][1]=0;
		Pow(a,m,n);
 	   printf("%lld\n",res[1][0]);
	}		
  return 0;
}

.

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值