POJ 3264 Balanced Lineup(线段树模板)

POJ3264
Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 79723 Accepted: 36409
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output

6
3
0

题意大概是给你一个区间的数,求给定的子区间的最大值和最小值。

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
const int maxn = 50005;
const int inf = 0x3f3f3f3f;
int Max[maxn << 2], Min[maxn << 2];
int ans1, ans2;
void build(int rt, int l, int r)
{
    if (l == r)
    {
        scanf("%d", &Max[rt]);
        Min[rt] = Max[rt];
        return ;
    }
    
        int mid = (l + r) >> 1;
        build(rt << 1, l, mid);
        build(rt << 1 | 1, mid + 1, r);
        Max[rt] = max(Max[rt << 1], Max[rt << 1 | 1]);
        Min[rt] = min(Min[rt << 1], Min[rt << 1 | 1]);
    
}

void query(int rt, int l, int r, int L, int R)
{
    if (L <= l && r <= R)
    {
        ans1 = max(ans1, Max[rt]);
        ans2 = min(ans2, Min[rt]);
    }
    else
    {
        int mid = (l + r) >> 1;
        if (L <= mid)
            query(rt << 1, l, mid, L, R);
        if (R > mid)
            query(rt << 1 | 1, mid + 1, r, L, R);
    }
}

int main()
{
    int n, m, L, R;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        build(1, 1, n);
        while (m--)
        {
            ans1 = -inf, ans2 = inf;
            scanf("%d%d", &L, &R);
            query(1, 1, n, L, R);
            printf("%d\n", ans1 - ans2);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值