二叉树的建立于遍历 基础



数据结构实验之二叉树的建立与遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后方式遍历二叉树最后求出叶子节点个数和二叉树深度

输入

  输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfa
cgefdba
3
5
 
 
 
 
#include <string.h>
#include <stdlib.h>
#include <stdio.h>

char a[100];
struct node
{
    char data;
    struct node *l,*r;
};

struct node *build(struct node *t)///建树
{
    char x;
    scanf("%c",&x);
    if ( x != ',')///','为空节点
    {
        t = (struct node *)malloc (sizeof (struct node));
        t -> data = x;
        t -> l = build (t->l);
        t -> r = build (t->r);
    }
    else
        t = NULL;
    return t;
}

void mid(struct node *t)///中序遍历
{
    if(t!=NULL)
    {
        mid(t->l);
        printf("%c",t->data);
        mid(t->r);
    }
}

void last(struct node *t)后序遍历
{
    if(t!=NULL)
    {
        last(t->l);
        last(t->r);
        printf("%c",t->data);
    }
}
int ans=0;
void leaf(struct node *q)// 叶子的节点
{
    if (q)
    {
        if((q->l==NULL)&&(q->r==NULL))///叶子左右孩子为空
        {
            ans++;
        }
        leaf(q->l);
        leaf(q->r);
    }
}
int DeepTree(struct node *p)///树的深度
{
    if (!p)
        return 0;
    else if(p)
    {
        int dl = DeepTree(p->l);
        int dr = DeepTree(p->r);
        return dl > dr ? dl+1:dr+1;///一一直到根节点
    }
    return 0;
}
int main()
{
    int h;
    struct node *tree = NULL;
    tree = build(tree);
    mid(tree);
    printf("\n");
    last(tree);
    printf("\n");
    leaf(tree);
    printf("%d\n",ans);
    h = DeepTree(tree);
    printf("%d\n",h);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值