PAT 1007 Maximum Subsequence Sum HERODING的PAT之路

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:
求最⼤连续⼦序列和,输出最⼤的和以及这个⼦序列的开始值和结束值。如果所有数都⼩于0,那么认为最⼤的和为0,并且输出⾸尾元素。

解题思路:
这道题看似简单,其实认真思考下来还是有很多细节的地方。首先我们要想到,如何去寻找最大连续子序列,一开始我思维定式认为只要序列有负数就不行,但是后来一想如果负数后面的正数序列和很大抵消了负数的效果不就没问题了吗?所以还是得接受负数,那什么时候要放弃当前序列呢?当前序列和为负数,无论如何都要丢弃了。

所以我想到用滑动窗口去写,但是新的问题出现了,滑动窗口确实能够确定大嘴子序列和,但是不能够固定该序列的开始位置和结束位置(因为在不断滑动),其实还是把问题考虑复杂了,既然我们只要最大序列,那么左右位置的更新只在最大位置更新就好不就行了吗?这就是最终的思路,还有几个注意事项如下:

  • 左右位置初始值为最左和最右,防止全为负数的情况。
  • max的初始值一定要是负数,因为如果序列是全0序列就无法更新了,导致输出的开始和结束还是头尾。

代码如下:

#include<iostream>
#include<vector>

using namespace std;

int main() {
    int n;
    cin >> n;
    vector<int> list(n);
    int left = 0, demoLeft = 0, right = n - 1, temp = 0, max = -1;
    for(int i = 0; i < n; i ++) {
        cin >> list[i];
        temp += list[i];
        if(temp < 0) {
            temp = 0;
            demoLeft = i + 1;
        } else if(temp > max) {
            left = demoLeft;
            right = i;
            max = temp;
        }
    }
    if(max < 0) max = 0;
    cout << max << " " << list[left] << " " << list[right];
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

HERODING77

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值