windows下Bitnami Redmine的安装

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/HHTNAN/article/details/80290996

项目管理工具是团队开发过程中必不可少的工具,比较流行的包括JIRA、trac、redmine、xplanner等。redmine系统以其轻量、易上手等特点吸引了越来越多人的注意,作为其特色的甘特图,也为其赢得了更多的称赞和口碑。 公司要进行敏捷开发管理,最后选择Redmine作为管理工具。
redmine是一个支持中文的开源项目管理系统,基于Ruby on Rails,支持功能灵活而丰富:多项目、多数据库支持、bug跟踪、甘特图、文档管理、wiki、email、论坛、时间线等,基本能够满足大多数项目管理需求。下面来看看安装redmine需要的支持环境和安装步骤。(请参考各平台安装redmine的官方说明) 。

安装

Bitnami Redmine官网:https://bitnami.com/stack/redmine下载对应版本,之后傻瓜式安装
这里写图片描述
安装好了后,打开Bitnami Redmine Stack管理工具,点击Go To Applocation,点击redmine,就可以使用redmine了。

Redmine部署及配置

这里写图片描述

常见问题:

Bitnami redmine常见问题与配置

《一》Bitnami redmine默认用的是80端口如何手动更改端口号;

下面以把端口号8081更改为3000为列:

需要更能两个文件

第一个:httpd.conf文件

F:\Bitnami\redmine-3.2.1-1\apache2\conf\httpd.conf下找到这行

#Listen 12.34.56.78:8081

Listen 8081

更改为


#Listen 12.34.56.78:3000

Listen 3000

在把下面
# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName localhost:8081
更改为
# If your host doesn't have a registered DNS name, enter its IP address here.


ServerName localhost:3000

第二个文件:bitnami.conf文件

F:\Bitnami\redmine-3.2.1-1\apache2\conf\bitnami

# Default Virtual Host configuration.



<IfVersion < 2.3 >

  NameVirtualHost *:8081

  NameVirtualHost *:443

</IfVersion>



<VirtualHost _default_:8081>

  DocumentRoot "F:/Bitnami/redmine-3.2.1-1/apache2/htdocs"

  <Directory "F:/Bitnami/redmine-3.2.1-1/apache2/htdocs">

    Options Indexes FollowSymLinks

    AllowOverride All

    <IfVersion < 2.3 >

      Order allow,deny                          

      Allow from all

    </IfVersion>

    <IfVersion >= 2.3 >

      Require all granted

    </IfVersion>

  </Directory>

更改为:

# Default Virtual Host configuration.



<IfVersion < 2.3 >

  NameVirtualHost *:3000

  NameVirtualHost *:443

</IfVersion>



<VirtualHost _default_:3000>

  DocumentRoot "F:/Bitnami/redmine-3.2.1-1/apache2/htdocs"

  <Directory "F:/Bitnami/redmine-3.2.1-1/apache2/htdocs">

    Options Indexes FollowSymLinks

    AllowOverride All

    <IfVersion < 2.3 >

      Order allow,deny                          

      Allow from all

    </IfVersion>

    <IfVersion >= 2.3 >

      Require all granted

    </IfVersion>

  </Directory>
展开阅读全文

没有更多推荐了,返回首页