杭电ACM 1005

8 篇文章 0 订阅

Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

解析:这个题关键是两个模7 进行49次就会 出现循环,所以我们可以将这 49个值 存储起来

看读懂的朋友可以将中间那行注释去掉,跑一下看看就知道了

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int[] template=new int[53];
        template[1]=1;
        template[2]=1;
        while(scanner.hasNext()){
            int a=scanner.nextInt();
            int b=scanner.nextInt();
            int n=scanner.nextInt();
            if(a==0&&b==0&&n==0)
                break;
            if(n==1||n==2)
                System.out.println(1);
            else{
                for(int i=3;i<53;i++){
                    template[i]=(a*template[i-1]+b*template[i-2])%7;
                    //System.out.println("i-->"+i+" value-->"+template[i]);
                }
                System.out.println(template[n%49]);
            }
        }

    }

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值