杭电acm 1005

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5

递归做的话会  Runtime Error (STACK_OVERFLOW)

#include <stdio.h>

#include <string.h>
int fac(int a,int b,int n)
{
if(n==1||n==2)
return 1;
else return (a*fac(a,b,n-1)+b*fac(a,b,n-2))%7;
}
int main(int argc, char *argv[])
{
int a,b,n;
int m;
while(scanf("%d%d%d",&a,&b,&n)!=EOF)
{
if(a==0&&b==0&&n==0)
break;
m=fac(a,b,n);
printf("%d\n",m);
}


return 0;
}



附上AC答案

#include <stdio.h>
int  main()
{
     int  a,b;
     long  n;
     int  f[201];
     int  i;
     while ( scanf ( "%d%d%ld" ,&a,&b,&n)!=EOF)
     {
         if (n==0&&a==0&&b==0)
             break ;
         f[1]=1;
         f[2]=1;
         if  (n>=3)
         {
             for (i=3;i<200;i++)
             {
                 f[i]=(a*f[i-1]+b*f[i-2])%7;
                 if  ((f[i-1]==1)&&(f[i]==1))
                 {
                     break ;
                 }
             }
             i=i-2;
             n%=i;
             if  (n==0)
             {
                 n=i;
             }
             printf ( "%d\n" ,f[n]);
         }
         else
         {
             printf ( "1\n" );
         }
     }
     return  0;
}

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
   
   
1 1 3 1 2 10 0 0 0
 

Sample Output
   
   
2 5
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
   
   
1 1 3 1 2 10 0 0 0
 

Sample Output
   
   
2 5
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值