洛谷 P2548 [AHOI2004]智能探险车

题目描述

输入输出格式

输入格式:

 

 

输出格式:

 

 

输入输出样例

输入样例#1: 复制
4 3
sunny plain full many
sunny mountain full many
sunny mountain full few
输出样例#1: 复制
sunny * full *
思路:首先是读题,很显然就是要求,如果全部相等,就输出,否则,就输出“*”。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 1007
using namespace std;
int n,m;
bool ans[maxn];
string t[maxn],gg;
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){
        cin>>gg;
        t[i]=gg;
    }
    for(int i=2;i<=m;i++)
        for(int j=1;j<=n;j++){
            cin>>gg;
            if(t[j]!=gg)    ans[j]=1;
        }
    for(int i=1;i<=n;i++)
        if(ans[i])    printf("* ");
        else    cout<<t[i]<<" ";
}

 

 

转载于:https://www.cnblogs.com/cangT-Tlan/p/8687818.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值