POJ 2406 Power Strings

题目链接

http://poj.org/problem?id=2406

题目

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n). 
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case. 
Output

For each s you should print the largest n such that s = a^n for some string a. 
Sample Input

abcd 
aaaa 
ababab 

Sample Output



3

题意

重新定义字符串乘法:两个字符串相乘等价于两个字符串首尾相连。现给定一个字符串s,将s用字符串a表示,求最大的n使得a^n=s。

题解

根据最小循环节的定义,loop=len-pre[len]。其中pre为kmp算法中的前缀数组(在有些书中叫next数组)。 
将字符串s看作由最小循环节组成的话,如果len恰好能整除loop,则ans=len/loop;否则,ans=len。

代码


#include <cstdio>
#include <cstring>
using namespace std;

const int maxn=1e6+100;
char t[maxn];
int pre[maxn],len,loop;

void init()
{
    memset(pre,0,sizeof(pre));
}

void getpre()
{
    memset(pre,0,sizeof(pre));
    int j=0;
    for(int i=2;i<=len;i++)
    {
        while(j>0 && t[j+1]!=t[i]) j=pre[j];
        if(t[j+1]==t[i]) j++;
        pre[i]=j;
    }
}

int main()
{
    while(scanf("%s",t+1))
    {
        init();
        if(strcmp(t+1,".")==0)
            break;
        len=strlen(t+1);
        getpre();
        loop=len-pre[len];
        printf("%d\n",len%loop==0?len/loop:1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值