HDU5972 Regular Number(bitset)

Regular Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1645    Accepted Submission(s): 446


Problem Description
Using regular expression to define a numeric string is a very common thing. Generally, use the shape as follows:
(0|9|7) (5|6) (2) (4|5)
Above regular expression matches 4 digits:The first is one of 0,9 and 7. The second is one of 5 and 6. The third is 2. And the fourth is one of 4 and 5. The above regular expression can be successfully matched to 0525, but it cannot be matched to 9634.
Now,giving you a regular expression like the above formula,and a long string of numbers,please find out all the substrings of this long string that can be matched to the regular expression.
 

Input
It contains a set of test data.The first line is a positive integer N (1 ≤ N ≤ 1000),on behalf of the regular representation of the N bit string.In the next N lines,the first integer of the i-th line is  ai(1ai10) ,representing that the i-th position of regular expression has  ai  numbers to be selected.Next there are  ai  numeric characters. In the last line,there is a numeric string.The length of the string is not more than 5 * 10^6.
 

Output
Output all substrings that can be matched by the regular expression. Each substring occupies one line
 

Sample Input
  
  
4 3 0 9 7 2 5 7 2 2 5 2 4 5 09755420524
 

Sample Output
  
  
9755 7554 0524
 

Source

题意:给n组数,从每组里选取出来一个数字,按顺序构成的新的串是合法的,其余均是不合法的。又给出一个串,问当中合法的字串有哪些
这个题需要使用bitset,将每个数字可以出现的位置所对应的二进制的相应的位置为1;
b[0]=1 0 0 0 0 0 
b[1]=0 0 0 0 0 0
b[2]=0 0 1 0 0 0
b[3]=0 0 0 0 0 0
b[4]=0 0 0 1 0 0
b[5]=0 1 1 1 0 0
b[6]=0 0 0 0 0 0
b[7]=1 1 0 0 0 0
b[8]=0 0 0 0 0 0
b[9]=1 0 0 0 0 0
比如b[0]表示0这个数字只能出现在第0位是合法的......
在使用二进制数,每次将这个数字右移一位,并将最低为置为1,和对应的母串的字符相与,以确定对应的数字是否合法。
直至1出现在n-1的位置上时,找到成功的字符串。
#include <stdio.h>
#include <string.h>
#include <bitset>
using namespace std;
const int N=1005;
bitset<N> ans;
bitset<N> dic[N];
char str[5000005];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            int k;
            scanf("%d",&k);
            for(int j=0;j<k;j++)
            {
                int tmp;
                scanf("%d",&tmp);
                dic[tmp].set(i);
            }
        }
        getchar();
        gets(str);
        int len=strlen(str);
        for(int i=0;i<len;i++)
        {
            ans=ans<<1;
            ans.set(0);
            ans=ans&dic[str[i]-'0'];
            if(ans[n-1]==1)
            {
                char s=str[i+1];
                str[i+1]='\0';
                puts(str+i-n+1);
                str[i+1]=s;
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值