HDU 3635 Dragon Balls(并查集)

本文介绍了一个基于并查集的编程问题,五百年后龙珠数量增多,导致孙悟空收集困难。问题涉及城市间龙珠的转移,需要回答每个龙珠所在城市、该城市龙珠总数及龙珠转移次数。输入包含测试用例数、城市和查询信息,输出相应城市、龙珠数量和转移次数。
摘要由CSDN通过智能技术生成

Problem Description 

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

理解

这是一道比较综合的有关并查集的题目,涉及路径压缩、统计节点以及统计合并次数。

代码

#include<iostream>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=10010;
int f[maxn],pnum[maxn],trannum[maxn];
int flag,flag1;
void init(int n){
	for(int i=1;i<=n;i++){
		f[i]=i;
		pnum[i]=1;
	} 
	memset(trannum,0,sizeof(trannum));
	flag1=1;
}
int find(int x){
	if(x!=f[x]){
		int t=f[x];
		f[x]=find(f[x]);
		trannum[x]+=trannum[t];//这里是一处细节,记得x的转移次数是加上x的没有路径压缩前的父节点的转移次数
	}
	return f[x];
}
void Union(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
		f[fx]=fy;
		pnum[fy]+=pnum[fx];//把fx代表的树的节点数加到以fy代表的树上
		trannum[fx]++;//fx代表的树转移次数加1
	}
}
int main(){
	int T;
	scanf("%d",&T);
	flag=1;
	while(T--){
		int n,q;
		scanf("%d%d",&n,&q);
		init(n);
		while(q--){
			if(flag1){
				printf("Case %d:\n",flag++);
				flag1=0;
			}
			char c;
			getchar();
			c=getchar();
			if(c=='T'){
				int a,b;
				scanf("%d%d",&a,&b);
				Union(a,b);
			}
			else{
				int i;
				scanf("%d",&i);
				int fi=find(i);
				printf("%d %d %d\n",fi,pnum[fi],trannum[i]);
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值