Dragon Balls(并查集)

Dragon Balls

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9 Accepted Submission(s) : 5
Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2

Author
possessor WC

Source
2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU

题目大意:

初始时,有n个龙珠,编号从1到n,分别对应的放在编号从1到n的城市中。

现在又2种操作:

T A B,表示把A球所在城市全部的龙珠全部转移到B城市。(第一次时,因为A球所在的城市只有一个球,所以只移动1个,如果有多个,则全部移动)。

Q A,表示查询A。要求得到的信息分别是:A现在所在的城市,A所在城市的龙珠数目,A转移到该城市移动的次数(如果没有移动就输出0)


题解:并查集,把这个城市的根结点的转移次数+1,等到以后路径压缩时,子结点自己移动的次数加上根结点移动的次数,就是这个结点总共的移动次数
#include<cstdio>
#include<string>
using namespace std;
const int M=10010;
int f[M],cnt[M],move[M];//父节点,该城市龙珠个数,移动步数
int n;
void init()
{
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        cnt[i]=1;
        move[i]=0;
    }
}
int find(int x)
{
    if(f[x]==x)return x;
    int t=f[x];
    f[x]=find(f[x]);
    move[x]+=move[t];
    return f[x];
}
void Union(int a,int b)
{
    int fa=find(a);
    int fb=find(b);
    if(fa!=fb)
    {
        f[fa]=fb;
        cnt[fb]+=cnt[fa];
        move[fa]=1;
    }
}
int main()
{
    int m,t,a,b,cases,icas=1;
    char c;
    scanf("%d",&cases);
    while(cases--)
    {
        scanf("%d%d",&n,&m);
        init();
        printf("Case %d:\n",icas);
        while(m--)
        {
            scanf("%c",&c);
        if(c=='T')
        {
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        else
        {
            scanf("%d",&a);
            int t=find(a);
            printf("%d %d %d",t,cnt[t],cnt[a]);
        }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值