poj 3494 dp+单调栈

Largest Submatrix of All 1’s
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 5088 Accepted: 1897
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with nnumbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

Source


求最大子矩阵(每一位都是1)

枚举每一个行,dp[n]前n行的最大子矩阵,如果最大子矩阵没用到最后一行则dp[n] = dp[n-1]。 如果用到第n行的话,因为矩阵必须是连续的,可以转换为poj 2559中n个宽都为相同的1,高度不同求最大面积问题,用单调栈的做法就可以仅用O(n)复杂度,总复杂度就是O(n^2)


#include <iostream>
#include <cstring>
#include <cstdio>
#include <stack>

using namespace std;

#define maxn 2001

int a[maxn][maxn];
int n, m;
int l[maxn], r[maxn];

int main()
{
    while(~scanf("%d %d", &m, &n)){
        for(int i = 1; i <= m; i++)
            for(int j = 1; j <= n; j++)
                scanf("%d", &a[i][j]);
        for(int j = 1; j <= n; j++)
            for(int i = 2; i <= m; i++)
            if(a[i-1][j] && a[i][j])
                a[i][j] += a[i-1][j];   //求出每一列从第i行的位置上去共有几个连续的1


        stack<int> s;
        int ans = 0;
        for(int i = 1; i <= m; i++){
            while(!s.empty()) s.pop();
            for(int j = 1; j <= n; j++){    //求第j个数的左边界
                while(!s.empty() && a[i][s.top()] >= a[i][j]) s.pop();
                l[j] = s.empty() ? 1 : s.top()+1;
                s.push(j);
            }
            while(!s.empty()) s.pop();
            for(int j = n; j >= 1; j--){    //求第j个数的右边界
                while(!s.empty() && a[i][s.top()] >= a[i][j]) s.pop();
                r[j] = s.empty() ? n : s.top()-1;
                s.push(j);
            }

            for(int j = 1; j <= n; j++)
                ans = max(ans, (r[j]-l[j]+1)*a[i][j]);
        }

        printf("%d\n", ans);


    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值