Poj 3494 (dp)

Largest Submatrix of All 1’s
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 4546 Accepted: 1700
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

Source


求一个0-1矩阵中全为1的最大子矩阵。这题关键是看出所求的子矩阵,一定是由某个位置的开始,向上连续1到的最高点的位置为高,向左右两边拓展得到的。这样我就只需先预处理每个点向上到的最高点,然后用一个单调栈,对每行都是O(n)的时间处理出它每个点往左往右的最远点。最后求相乘的最大面积即可。复杂度O(n^2)。
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
const int maxn = 2000 + 5;
const int INF = 2000000000;
typedef  pair<int, int> P;
typedef long long LL;

int n,m;
int M[maxn][maxn];
int u[maxn][maxn];

void pre(){
    memset(u,0,sizeof(u));
    for(int i = 1;i <= n;i++){
        for(int j = 1;j <= m;j++){
            if(M[i][j] == 0) u[i][j] = 0;
            else u[i][j] = u[i-1][j]+1;
        }
    }
}

stack<P> S;
int l[maxn][maxn],r[maxn][maxn];

int main(){
    while(scanf("%d%d",&n,&m) != EOF){
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= m;j++){
                scanf("%d",&M[i][j]);
            }
        }
        pre();
        for(int i = 1;i <= n;i++){
            while(!S.empty()) S.pop();
            for(int j = 1;j <= m;j++){
                while(!S.empty() && u[i][j] <= S.top().first) S.pop();
                if(S.size() == 0) l[i][j] = 1;
                else l[i][j] = S.top().second+1;
                S.push(P(u[i][j],j));
            }
        }
        for(int i = 1;i <= n;i++){
            while(!S.empty()) S.pop();
            for(int j = m;j >= 1;j--){
                while(!S.empty() && u[i][j] <= S.top().first) S.pop();
                if(S.size() == 0) r[i][j] = m;
                else r[i][j] = S.top().second-1;
                S.push(P(u[i][j],j));
            }
        }
        int ans = 0;
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= m;j++){
                ans = max(ans,u[i][j]*(r[i][j]-l[i][j]+1));
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值