Eight HDU 1043 BFS+打表+康托展开

问题:

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

题目大意:给一个状态让你变成给定状态12345678X,输出路径,如果不行输出unsolvable;注意:路径不唯一。

思路:把所有的情况都列出来,例1 2 3 4 5 6 7 x 8,只需将x向右移动一次,并记录这个路径。康托展开:详细介绍:https://blog.csdn.net/qq_38701476/article/details/81003290

        for(int i=0; i<9; i++)
        {
            int ll=0;
            for(int j=i+1; j<9; j++)
                if(w[i]>w[j])
                    ll=ll+1;
            num=num+ll*jc[8-i];
        }

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
    int h,x,y,z,b[5][5];//x横坐标,y纵坐标
};
int s[5][5],book[400000],jc[11];
char book1[400000];
int to[4][2]= {{1,0},{0,1},{-1,0},{0,-1}} ;//方向d,r,u,l;
void bfs()
{
    queue<node>q;
    node u,v;
    u.h=9;
    u.x=2;
    u.y=2;
    u.z=0;
    for(int i=0; i<3; i++)
        for(int j=0; j<3; j++)
            u.b[i][j]=s[i][j];
    book[0]=0;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            v=u;
            int dx=u.x+to[i][0];
            int dy=u.y+to[i][1];
            if(dx>=0&&dx<3&&dy>=0&&dy<3)
            {
                v.h=u.b[dx][dy];
                v.x=dx;
                v.y=dy;
                int tt;//交换位置
                tt=u.b[dx][dy];
                v.b[dx][dy]=u.b[u.x][u.y];
                v.b[u.x][u.y]=tt;
                int kk[10];
                int o=0;
                for(int i=0; i<3; i++)
                    for(int j=0; j<3; j++)
                        kk[o++]=v.b[i][j];
                int sum=0;
                for(int i=0; i<9; i++)//康托展开
                {
                    int l=0;
                    for(int j=i+1; j<9; j++)
                        if(kk[i]>kk[j])
                            l=l+1;
                    sum=sum+l*jc[8-i];
                }
                v.z=sum;
                if(book[sum]==-1)//记录路径
                {
                    book[sum]=u.z;
                    if(i==0)
                        book1[sum]='u';
                    if(i==1)
                        book1[sum]='l';
                    if(i==2)
                        book1[sum]='d';
                    if(i==3)
                        book1[sum]='r';
                    q.push(v);
                }
            }
        }
    }
}
int main()
{
    int t=1;
    for(int i=0; i<3; i++)
        for(int j=0; j<3; j++)
            s[i][j]=t++;
    for(int i=0; i<400000; i++)
        book[i]=-1;
    jc[0]=0;
    jc[1]=1;
    for(int i=2; i<9; i++)//阶乘
        jc[i]=i*jc[i-1];
    bfs();
    char n[100],m[10];
    int w[10];
    while(gets(n))
    {
        int d=strlen(n),f=0;
        for(int i=0; i<d; i++)
            if(n[i]!=' ')
                m[f++]=n[i];
        if(m[0]=='E'&&m[1]=='O'&&m[2]=='F')
            break;
        int ff=0;
        for(int i=0; i<f; i++)
        {
            if(m[i]!='x')
                w[ff++]=m[i]-48;
            if(m[i]=='x')
                w[ff++]=9;
        }
        int num=0;
        for(int i=0; i<9; i++)
        {
            int ll=0;
            for(int j=i+1; j<9; j++)
                if(w[i]>w[j])
                    ll=ll+1;
            num=num+ll*jc[8-i];
        }
        if(book[num]==-1)
            printf("unsolvable");
        else
            while(num!=0)
            {
                printf("%c",book1[num]);
                num=book[num];
            }
        printf("\n");
    }
    return 0;
}
//1 2 3 4 x 5 6 7 8  rdllurdrulldrr

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值