Leading and Trailing LightOJ - 1282 快速幂

问题:

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意:求n^k的前三位和后三位。

思路:1、后三位快速幂取模,注意不足三位补前导零。补前导零:假如n^k为1234005,快速幂取模后,得到的数是5,因此输出要补前导零。注意:前导零(%03d)输出;

2、前三位:令n=10a,则nk=10ak=10x+y,x为ak的整数部分,y为ak的小数部分。

例:n=19,k=4,则n^k=130321,

a=log10(n)=1.2787536009528289615363334757569

a*k=5.1150144038113158461453339030277,

因此,x=5,y=0.1150144038113158461453339030277,

10y=1.3032099999999999999999999999999,因此要获得前三位只需要10y*100下取整即可。

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int kk=1,t;
    scanf("%d",&t);
    while(t--)
    {
        long long a,b,sum=1;
        scanf("%lld%lld",&a,&b);
        long long n=a,m=b;
        if(a>1000)
            a=a%1000;
        while(b>0)
        {
            if(b%2!=0)
                sum=(sum*a)%1000;
            b=b/2;
            a=(a*a)%1000;
        }
        sum=sum%1000;
        double l=2+m*log10(n);
        int ll=m*log10(n);
        int k=pow(10,l-ll);
        printf("Case %d: %d %03lld\n",kk++,k,sum);//注意输出
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值