B - stl 的 map

stl 的 map

题目描述

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Iutput

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘\t’), enter(‘\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i’m fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i’m from mars.
i like earth!

Hint

Huge input, scanf is recommended.


思路:

首先用map构建字典,然后读入字符串,每次复制下一个单词的内容,然后判断是否在map中来输出;


代码

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
#include <cstring>
#include <cctype>
using namespace std;
map <string , string > mymap;
int main()
{
    int i,j,k;
    string mar,earth,s;
    cin>>s;//start,不需要吸收换行符,因为上下均为cin
    while(cin>>earth)
    {
        if(earth == "END")
            break;
        cin>>mar;
        mymap[mar]=earth;
    }
    //cin>>s;//start,若是getline则需要 吸收上一次的换行符
    //getchar();
    getline(cin, s);    // filter '\n'
    getline(cin, s);
    string sec,code;
    while(getline(cin,sec))
    {
        if(sec=="END")
            break;
        for(i=0;i<sec.size();i++)
        {
            if(isalpha(sec[i]))  //包含在ctype头文件中,用于判断字符变量是否是英文字母。
                                //如是,则返回非零值,反之则返回零值。
            {
                code+=sec[i];
                if(!isalpha(sec[i+1]))
                {
                    if(mymap[code]!="")//map返回一个string
                        cout<<mymap[code];
                    else
                        cout<<code;//原来写成了sec,和sec[i]
                    code.clear();
                }
            }
            else
                cout<<sec[i];
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值