W - stl 的 优先队列

stl 的 优先队列

题目描述

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

思路:

题意:
一个人在路上走,一路上有n个石子位于stone[i].x位置,可以扔出的最大距离为stone[i].y,现在规定,遇到奇数位置的石子,捡起石子向前仍,遇到偶数位置的石子,不动它,继续向前走,若两块石子在同一个位置,则先看到stone[i].y小的石子,问石子能达到的最远距离;
这题是优先队列专题练手的,构造结构体时需从载运算符,规定结构体成员的优先级,每次遇到一个石头,先判断是奇是偶,是奇数则修改stone[i].x=stone[i].x+stone[i].y,继续入队列,偶数的只出不进;

代码

#include <cstdio>
#include <queue>
using namespace std;
struct node
{
    int x,y;
    friend bool operator < (node a,node b)
    {
        if(a.x==b.x)
            return a.y>b.y;
        return a.x>b.x;
    }
} stone;
int main()
{
    priority_queue<node> q;

    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&stone.x,&stone.y);
            q.push(stone);
        }

        int num=1,dis=0;
        while(!q.empty())
        {
            stone=q.top();
            q.pop();

            if(num%2)
            {
                dis=stone.x+stone.y;
                stone.x=dis;
                q.push(stone);
            }
            num++;
        }
        printf("%d\n",dis);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值