(2)W - stl 的 优先队列

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output Just output one line for one test case, as described in the Description.
Sample Input
2
2
1 5
2 4
2
1 5
6 6
Sample Output
11
12

题意:给n个石头的pi,和能够达到的距离,从0往右走,如果是遇到的第偶数个石头,就原地不动,第奇数个就可以仍。思路:判断是第奇数个及该不该仍。优先队列模拟,根据小堆优先。关于优先队列我又专门去查找资料,了解了一下,虽然前面写过但是并不了解。现在仍旧不怎么理解
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
struct node
{
 int p;
 int d;
 friend bool operator<(node x,node y)//基本语法
 {
  if(x.p==y.p)
  {
   return x.d>y.d;
  }
  else
  {
   return x.p>y.p;
  }
 }
};
int main()
{
 int t,i,j,n;
 struct node temp;
 cin>>t;
 int flag;
 while(t--)
 {
  flag=1;
  priority_queue<node>m;//优先队列的定义(有很多种,这只是其中一种)
  cin>>n;
  for(i=0;i<n;i++)
  {
   cin>>temp.p>>temp.d;
   m.push(temp);
  }
  while(!m.empty())
  {
   temp=m.top();
   m.pop();
   if(flag%2!=0)//判断该不该仍
   { 
    temp.p+=temp.d;
    m.push(temp);   
   }
   flag+=1;
  }
  cout<<temp.p<<endl;//剩下的最后一个一定是最远距离
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值