Y - 栈

Y - 栈

题目描述

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it’s too short), neither is
i i o o o i (there’s an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Iutput

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in “dictionary order”. Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o
i i i i o o o o i o
i i o i o i o i o o
i i o i o i o o i o
]
[
i o i i i o o i i o o o
i o i i i o o o i o i o
i o i o i o i i i o o o
i o i o i o i o i o i o
]
[
]
[
i i o i o i o o
]


思路:

题目意思,就是利用栈使得源字符串经过优先步骤后变成目标字符串。

解题步骤:

本题是典型的回溯算法,可以参考深度优先算法,用栈来保存操作步骤;


代码

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
#include <stack>
using namespace std;
string st1,st2;
int len;
stack <char> a;
vector <char> b;
void dfs(int ipush,int ipop)
{
    if(ipush==len&&ipop==len)//边界,构造完成。
    {
        for(int i=0;i<b.size();i++)
            printf("%c ",b[i]);
        printf("\n");
        return;
    }
    if(ipush+1<=len)//元素入栈。
    {
        a.push(st1[ipush]);
        b.push_back('i');
        dfs(ipush+1,ipop);
        a.pop();//回溯。
        b.pop_back();
    }
    if(ipop+1<=len&&a.size()>=1&&a.top()==st2[ipop])//出栈,保证不会爆栈,且栈顶元素恰为st2中所需字符。
    {
        char now=a.top();
        a.pop();
        b.push_back('o');
        dfs(ipush,ipop+1);
        a.push(now);//回溯。
        b.pop_back();
    }
}
int main()
{
    while(cin>>st1>>st2)
    {
        len=st1.length();
        printf("[\n");
        dfs(0,0);//dfs(ipush,ipop)表示st1与st2中末尾字符下标。也是目前入栈出栈次数。
        printf("]\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值