SZ斐波拉契数列

Problem Description

Fibonacci sequence is familiar to you, right? Here comes the SZ Fibonacci sequence, with the property like the following formula.
F(n)= a (n=1)
F(n)= b (n=2)
F(n)= F(n-1)+F(n-2), n>2 and n is odd
F(n)= F(n-1)+F(n-2)+F(n-3), n>2 and n is even
Here a and b are constants. Given a,b,and n, your task is to calculate the F(n).

Input

First line of input comes a positive integer T(T<=10), indicating the number of test cases. Each test case contains three positive integer a,b and n(a<=10,b<=10,n<=30)

Output

Print one line containing an integer, i.e.F(n), for each test case.

Sample Input

2
1 2 3
1 3 6

Sample Output

3
24
 
#include<iostream>
#include<cstdio>
using namespace std;
int a,b;
int dg(int );
int main()
{
//freopen("a.txt","r",stdin);
int c,n;
scanf("%d",&n);
while(n--)
{
scanf("%d%d%d",&a,&b,&c);
printf("%d\n",dg(c));
}
return 0;
}
int dg(int c)
{
if(c==1) return a;
if(c==2) return b;
if(c>2&&c%2==0) return dg(c-1)+dg(c-2)+dg(c-3);
if(c>2&&c%2!=0) return dg(c-1)+dg(c-2);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值