c++逆反的01串

输入

0110100100100 1000000010000000000

输出

1001011011011 0111111101111111111

样例输入 

0110100100100
1000000010000000000

样例输出 

1001011011011
0111111101111111111

#include<iostream>
#include<iomanip>
#include<vector>
#include<string>
#include<cmath>
using namespace std;
int main()
{
	string s;
	while (getline(cin, s))
	{
//		cout << s << endl;
		int len = s.length();
		vector<char>word(len);
//		cout << len << endl;
		for (int i = 0; i <len; i++)
		{
			word[i] = s[i];
//			cout << s[i] << " ";
//			cout << word[i];
		}
		for (int i = 0; i < len; i++)
		{
			if (word[i] == '0')
			{
				cout << 1;
			}
			else if (word[i] == '1')
			{
				cout << 0;
			}
		}
		cout << endl;
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值