POJ 2251 Dungeon Master (简单三维广搜)

Dungeon Master

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output


 
Escaped in 11 minute(s).
Trapped!
  解题思路:

合理利用结构体、队列、标记  将每一个步骤、每一种情况思考全面

#include<cstdio>
#include<queue>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxx = 35;
char mapp[maxx][maxx][maxx];
int l,m,n,step[maxx][maxx][maxx],ez,ex,ey;
int book[maxx][maxx][maxx];
int nex[6][3]={0,1,0,  0,0,1,  1,0,0,  0,-1,0,  0,0,-1,  -1,0,0,};   //枚举每种移动
struct node
{
    int x,y,z;
}s,t,now; 
void bfs();
int main()
{
    int i,j,k;
    while(scanf("%d%d%d",&l,&m,&n),l+m+n){
        for(i=0;i<l;i++){
            for(j=0;j<m;j++){
                for(k=0;k<n;k++){
                    scanf(" %c",&mapp[i][j][k]);
                    if(mapp[i][j][k]=='S'){
                        s.z=i;
                        s.x=j;
                        s.y=k;
                    }
                    else if(mapp[i][j][k]=='E'){
                        ez=i;
                        ex=j;
                        ey=k;
                    }
                }
            }
        }
        memset(step,0x3f,sizeof(step));                //初始化
        memset(book,0,sizeof(book));
        step[s.z][s.x][s.y]=0;
        book[s.z][s.x][s.y]=1;
        bfs();
        if(step[ez][ex][ey]==inf)  printf("Trapped!\n");
        else     printf("Escaped in %d minute(s).\n",step[ez][ex][ey]);
    }
    return 0;
}
void bfs()
{
    queue<node>q;
    q.push(s);
    while(!q.empty()){
        t=q.front();
        if(t.z==ez&&t.x==ex&&t.y==ey)  return ;        // 如果到达终点 返回
        q.pop();                                       //入队
        for(int i=0;i<6;i++){
            now.z=t.z+nex[i][0];
            now.x=t.x+nex[i][1];
            now.y=t.y+nex[i][2];
            if(now.z<0||now.z>=l||now.x<0||now.x>=m||now.y<0||now.y>=n)  continue;//判断当前的值是否出地图
            if(mapp[now.z][now.x][now.y]=='#') continue;                          //判断当前位置是否是墙
            if(book[now.z][now.x][now.y]==1)   continue;                          //判断当前是否被标记
            step[now.z][now.x][now.y]=step[t.z][t.x][t.y]+1;
            book[now.z][now.x][now.y]=1;                                          //标记
            q.push(now);                                                          //入队
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值