String Subtraction (20)

题目描述

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.

输入

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出

For each test case, print S1 - S2 in one line.

样例输入

They are students.
aeiou

样例输出

Thy r stdnts.

 

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
using namespace std;
int hashfunc(char c)
{
    return int(c);
}
int main()
{
    string s1,s2;
    getline(cin,s1);
    getline(cin,s2);
    int l1=s1.length(),l2=s2.length();
    int ht[300];
    memset(ht,0,sizeof(ht));
    queue<char> q;
    for(int i=0;i<l1;i++)
    {
        q.push(s1[i]);
    }
    for(int i=0;i<l2;i++)
    {
        int id=hashfunc(s2[i]);
        ht[id]++;
    }
    while(!q.empty())
    {
        int id=hashfunc(q.front());
        if(ht[id]!=0)
            q.pop();
        else
        {
            cout<<q.front();
            q.pop();
        }
    }
    cout<<endl;
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值