问题 D: String Subtraction (20)--《算法笔记》

题目描述
Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2for any given strings. However, it might not be that simple to do it fast.
输入
Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
输出
For each test case, print S1 - S2 in one line.
样例输入 Copy
They are students.
aeiou
样例输出 Copy
Thy r stdnts.

注意ASCII码是128个,字符串的结尾是’\0’

代码如下:

#include<iostream>
#include<cstring>
using namespace std;
char S1[10010];
char S2[10010];
int main(){
	while(gets(S1)!=NULL){
		bool a[130] = {false};
		gets(S2); 
		for(int i=0;S2[i]!='\0';i++){
			a[S2[i]]=true;
		}
		for(int i=0;S1[i]!='\0';i++){
			if(a[S1[i]]==false){
				printf("%c",S1[i]);
			}
		}	
		printf("\n");
	}
	return 0;
}

一切代码都是AC过的,坚持原创
关注算法,打赏并留言,会和小新成为志同道合的好友哦
在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值