PAT甲级1052:Linked List Sorting (25)

题目

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

易错点

  1. 测试点4:考查的是对脏数据的处理,即给出的首地址在链表各个结点当中的首地址中找不到时的输出,如测试样例:

    3 -1
    54322 2 -1
    09876 90 12345
    12345 9 09868
    

    输出应当为0 -1,前面的0表示该链表没有任何结点,-1表示首地址为空。

  2. 可能存在给出的结点不在链表当中的情况,因此需要判断每一个结点是否链表当中,然后对在链表当中的元素进行排序。

代码

#include<bits/stdc++.h>
using namespace std;
struct Node{
    int address;
    int key;
    int next;
    int in_list;//标记是否在链表当中
};

struct Node N[100000];//<10^5,里面的int会自动初始化为0

int cmp(const void *a, const void *b){
    struct Node c = *(struct Node *)a;
    struct Node d = *(struct Node *)b;
    if (c.in_list==d.in_list)
        return c.key - d.key;//升序
    else
        return d.in_list - c.in_list;//降序,在链表中的排列在前面
}

int main(){
    int n,s,i,t1,t2,t3,y=0,num=0;//num记录链表中的结点的实际个数
    scanf("%d %d",&n,&s);
    for (i=0;i<n;i++)
    {
        scanf("%d %d %d",&t1,&t2,&t3);
        N[t1].address = t1;
        N[t1].key = t2;
        N[t1].next = t3;
        if (t1==s)
            y = 1;//说明链表是存在的(能找到链表的开始)
    }
    if (y==0)
        printf("0 -1");
    else
    {
        do{
            N[s].in_list = 1;//在链表中
            s = N[s].next;
            num++;
        }while (s!=-1);
        qsort(N,100000,sizeof(N[0]),cmp);
        printf("%d %05d\n",num,N[0].address);
        for (i=0;i<num;i++)
        {
            if (i!=(num-1))
                printf("%05d %d %05d\n",N[i].address,N[i].key,N[i+1].address);
            else
                printf("%05d %d -1",N[i].address,N[i].key);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值