A Bug's Life POJ - 2492

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint

Huge input,scanf is recommended.


思路:这题比较好理解,用x+n来表示能与x交配的所有编号的虫子,如果发现两个互相交配的虫子AB同时可以交配同一个虫子C,那证明有homo虫。

#include <stdio.h>
int parent[2005+2005];
int find(int x)
{
    return (x==parent[x])?x:parent[x]=find(parent[x]);
}
void init(int a)
{
    for(int i=1;i<=2*a;i++)
        parent[i]=i;
}
int same(int x,int y)
{
    return find(x)==find(y);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y) return ;
    else    parent[y]=x;
}
int main(void)
{


    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
        {
        int flag=0;
        int amount,pair;
        scanf("%d%d",&amount,&pair);
        init(amount);
        for(int i=1;i<=pair;i++)
        {
            int num1,num2;
            scanf("%d%d",&num1,&num2);
            if(same(num1,num2)==1)  
                flag=1;
            else
                unite(num1+amount,num2),unite(num1,num2+amount); // 关键
        }
        if(flag)
            printf("Scenario #%d:\nSuspicious bugs found!\n\n",i);
        else
            printf("Scenario #%d:\nNo suspicious bugs found!\n\n",i);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值